alexandria/documents/by-course/math-8/pset-1/package.nix
Youwen Wu 15f7d08901
Some checks are pending
Deploy Quartz site to GitHub Pages using Nix / build (push) Waiting to run
Deploy Quartz site to GitHub Pages using Nix / deploy (push) Blocked by required conditions
auto-update(nvim): 2025-01-06 20:03:55
2025-01-06 20:03:55 -08:00

37 lines
654 B
Nix

{
pkgs,
typstPackagesCache,
typixLib,
cleanTypstSource,
flakeSelf,
...
}:
let
src = cleanTypstSource ./.;
commonArgs = {
typstSource = "main.typ";
fontPaths = [
# Add paths to fonts here
# "${pkgs.roboto}/share/fonts/truetype"
];
virtualPaths = [
# Add paths that must be locally accessible to typst here
# {
# dest = "icons";
# src = "${inputs.font-awesome}/svgs/regular";
# }
];
XDG_CACHE_HOME = typstPackagesCache;
SOURCE_DATE_EPOCH = builtins.toString flakeSelf.lastModified;
};
in
typixLib.buildTypstProject (
commonArgs
// {
inherit src;
}
)