20 lines
571 B
Nix
20 lines
571 B
Nix
{
|
|
description = "Flake for a NixOS Mac Mini server.";
|
|
|
|
inputs = {
|
|
# NixOS official package source, using the nixos-23.11 branch here
|
|
nixpkgs.url = "github:NixOS/nixpkgs/nixos-24.05";
|
|
};
|
|
|
|
outputs = { self, nixpkgs, ... }@inputs: {
|
|
# Please replace my-nixos with your hostname
|
|
nixosConfigurations.gallium = nixpkgs.lib.nixosSystem {
|
|
system = "x86_64-linux";
|
|
modules = [
|
|
# Import the previous configuration.nix we used,
|
|
# so the old configuration file still takes effect
|
|
./configuration.nix
|
|
];
|
|
};
|
|
};
|
|
}
|