mirror of
https://github.com/youwen5/nixos.git
synced 2025-01-17 20:52:09 -08:00
25 lines
554 B
Nix
25 lines
554 B
Nix
{
|
|
inputs,
|
|
config,
|
|
lib,
|
|
...
|
|
}:
|
|
let
|
|
cfg = config.liminalOS;
|
|
in
|
|
{
|
|
options.liminalOS.integrateHomeManager = lib.mkOption {
|
|
type = lib.types.bool;
|
|
default = cfg.enable;
|
|
description = ''
|
|
Whether to activate home manager with default options. Keep in mind you still have to import the liminalOS home-manager module.
|
|
'';
|
|
};
|
|
|
|
config.home-manager = lib.mkIf cfg.integrateHomeManager {
|
|
useGlobalPkgs = true;
|
|
useUserPackages = true;
|
|
backupFileExtension = "backup";
|
|
extraSpecialArgs = { inherit inputs; };
|
|
};
|
|
}
|