liminalOS/hm/modules/linux/desktop-environment/default.nix
2025-01-16 21:30:58 -08:00

23 lines
411 B
Nix

{
osConfig,
lib,
...
}:
{
imports = [
./hyprland
./niri
./waybar
./swaync.nix
];
options.liminalOS.desktop = {
enable = lib.mkOption {
type = lib.types.bool;
default = osConfig.liminalOS.desktop.enable;
description = ''
Whether to enable the default configuration for the userland portions of the liminalOS desktop environment.
'';
};
};
}