mirror of
https://github.com/youwen5/nixos.git
synced 2025-01-18 05:02:10 -08:00
23 lines
476 B
Nix
23 lines
476 B
Nix
{
|
|
spicepkgs,
|
|
config,
|
|
osConfig,
|
|
lib,
|
|
...
|
|
}:
|
|
{
|
|
config = lib.mkIf (config.liminalOS.programs.enable && osConfig.liminalOS.config.allowUnfree) {
|
|
programs.spicetify = {
|
|
enable = true;
|
|
# theme = spicepkgs.themes.dribbblish;
|
|
# colorScheme = "rosepine";
|
|
enabledExtensions = with spicepkgs.extensions; [
|
|
lastfm
|
|
fullAppDisplayMod
|
|
];
|
|
enabledCustomApps = with spicepkgs.apps; [
|
|
lyricsPlus
|
|
];
|
|
};
|
|
};
|
|
}
|